Server 2009

CompatabilityLevel

Example code is for an older version of Server, newer code is available.
<?php
// Copyright (c) 2019 ActivePDF, Inc.
// ActivePDF Server 2009
// Example generated 09/21/19 
?>

<?php
// Get current path
$strPath = dirname(__FILE__) . "\\";

// Instantiate Object
$oSVR = new COM("APServer.Object");

// Specify the PDF version for the created PDF
// 0 = PDF Specification 1.3 (Default)
// 1 = PDF Specification 1.4
// 2 = PDF Specification 1.5
$oSVR->CompatabilityLevel = 1;

// Convert the PostScript file into PDF
$intPSToPDF = $oSVR->PSToPDF($strPath . "PS.ps", $strPath . "CompatabilityLevel.pdf");
if ($intPSToPDF != 0) {
  Error("PSToPDF", $intPSToPDF);
}

// Release Object
$oSVR = null;

// Process Complete
echo "Done!";

// Error Handling
function Error($method, $outputCode) {
  echo "Error in " . $method . ": " . $outputCode;
}
?>

Copyright © 2019 ActivePDF, Inc